Installation Guide for Linux (Redhat/CentOS & Ubuntu)

This installation Guide is intended for  COMMZGATE Messaging Server v4.3 for Linux (2011)

1) Overview & Installation

Download and extract the COMMZGATE_Messaging_Server_v4.3-linux.tar.gz package to an installation location of your choice   eg. /home/joe/  or  /usr/local/
The extracted directory contains the following structure
apache-tomcat      bin      conf      db-derby      log        sys

COMMZGATE Messaging Server v4.3 consists of 3 components:




All 3 must be running for COMMZGATE Messaging Server to function properly.

Starting all 3 can be done using "commzgate_ctl" found in the bin directory.

2) Starting and Stopping

To start COMMZGATE, run this command found in <INSTALL DIR>/COMMZGATE_Messaging_Server_v4.3-linux/bin

./commzgate_ctl start



./commzgate_ctl stop

3) Logging to the Web Interface

Upon installation, login to the Web Management interface at

The default login ID and password can be found in the README file in your installation package.
Please change the default password immediately upon login!


4) GSM transceiver modem device

You will require a GSM modem device with a working SIM card to send and receive SMS.
Devices can be purchased from

Default configured modem port for Linux is /dev/ttyS0

If you are using the USB version of our modem device, change the port setting to /dev/USB0, /dev/ttyUSB0 or the correct port that your OS has assigned the USB connection.

You can configure the port that your device is connected to by logging to the COMMZGATE Web Management interface and going to: Configure > Preferences


  • Avatar
    CommzGate Support

    If you are installing on a 64-bit system and face this error:
    "/lib/ bad ELF interpreter: No such file or directory"
    32 bit libraries are missing from your system

    You can fix this with the following steps:

    On any RPM based distribution (CentOS/RedHat/Fedora/Suse/Mandriva):
    yum -y install glibc.i686

    On any DEB based distribution (Debian/Ubuntu/Mint/Crunchbang):
    apt-get update
    apt-get install ia32-libs

Please sign in to leave a comment.